[doc] TODO.txt: GLEW and the Fast Blur shader have been ported from gens-qt4 to gens...
authorDavid Korth <gerbilsoft@gerbilsoft.com>
Wed, 2 Sep 2015 01:41:45 +0000 (21:41 -0400)
committerDavid Korth <gerbilsoft@gerbilsoft.com>
Wed, 2 Sep 2015 01:41:45 +0000 (21:41 -0400)
GLEW doesn't support checking for GL_APPLE_packed_pixels for some reason,
but if your video card is old enough to not support OpenGL 1.2, chances
are it can't run Gens/GS II, either. (Well, either that or you're using
Remote Desktop, which has OpenGL 1.1 with GL_EXT_bgra and a few other
Microsoft-specific extensions.)

doc/TODO.txt

index 0548724..1966bca 100644 (file)
@@ -37,15 +37,7 @@ libzomg:
 - Rename ZomgBase to SaveBase so it doesn't get confused with the Zomg class.
 
 OpenGL (gens-sdl):
-- Check for GL 1.2 instead of checking for GL_EXT_packed_pixels.
-  - GL 1.2 has GL_EXT_packed_pixels plus 565.
-  - GL_EXT_packed_pixels doesn't have 565.
-  - GL_APPLE_packed_pixels has 565, but is obsoleted by GL 1.2.
-  - GL_EXT_bgra is also built into GL 1.2.
-    - Still needed for GL 1.1, i.e. Windows GDI renderer.
 - Aspect ratio constraint: Use integers?
-- Add Fast Blur using shaders. (hotkey F9)
-  - Currently available using SW rendering.
 
 Windows:
 - Set console code page to UTF-8.